6

I made a spreadsheet, a part of which uses the IMPORTHTML function to get data from this webpage. For the first couple of weeks that it ran, it worked pretty great, getting all the data from the table as needed. I use the function 3 times, to get the results from the 3 different tables on the page.

What I've written is: =IMPORTHTML("http://www.parkrun.org.uk/results/juniorclubs/?eventname=norwich-juniors","table", 3) in a cell.

It worked fine for a couple of weeks, but now just says that it can't fetch the URL. It returns the same error in a completely blank spreadsheet. What's up with this - have I made a really obvious mistake, or did Google change the way that the function should be used? Could something else affect this?

  • 1
    Google hasn't changed anything. That pattern still works on other sites. This might be related stackoverflow.com/questions/32133716/… – Tom Woodward Apr 23 '16 at 20:35
  • 1
    Neither HTTP or HTTPS working for me on 5/15/2017. The former version stopped working last week. Very frustrating! – David May 15 '17 at 23:10
  • @David did you ever fix this? I'm having exactly the same problem now – Charlie Harding Dec 12 '18 at 21:37
  • Getting NA today with the code. Is something blocking the Google service? – hhh Apr 15 at 15:05
7

Oddly enough - in this exact situation - I played around with the page, a couple functions, variations, but the change that actually pulled in the data was simply changing the url from http to https..

see below image for live content successfully pulled

enter image description here

  • Just dropping by to upvote this and mention that switching to HTTPS also fixed my Yahoo Finance synchronization issue. Many thanks! If someone else out there uses the Investment Moats portfolio tracker, I hope Google directed you to this page :) – Laur Jan 25 '17 at 22:29
  • Worked for me... – neo269 Mar 13 '18 at 10:43
  • Note that this Google Groups thread suggests the opposite (i.e., dropping the 's'). In my case, neither works... – Jess Riedel Mar 19 '18 at 13:45
  • What worked for me (luckily, this time) was dropping the 's' to 'http://'. It looks like google caches http requests, and if one fails, it caches the fail too. So if you want to get it to immediately retry, you need to actually change the url. – fuzzyTew Mar 1 at 11:15
  • 1
    Getting NA today with the code. Is something blocking the Google service? – hhh Apr 15 at 15:05

protected by Community May 16 '17 at 5:47

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.