2

I reinstalled Windows 10. Windows 10 has the correct time zone. However, Gmail is 2 hours ahead of me (+10 GMT), while I am in +8 GMT.

I checked this Q/A and found no current answers.

I see the wrong time on the right hand side of each email in my inbox. For instance, at 18:00 my time, if I see a new email, it will display 20:00.

Email I send has an email header: Delivery-date: Mon, 16 May 2016 20:39:53 +1000.

Any current answers would be appreciated. Google doesn't really help much on this issue.

Update: I answered below that updating my Windows timezone resolve this issue, but in the time since, the original symptom has re-emerged, for an unknown reason. i.e Local Windows timezone is +8GMT, Google Calendar timezone is +8GMT, but gmail emails in my inbox at 13:00 (+8GMT) my time are displaying as 15:00 in gmail.

Update2: Windows time, although reset to +8GMT, was still 2 hours behind, despite my PC connecting to the Internet for the correct time. Manually setting my time to the correct time resolve the Gmail issue.

  • I'm wondering if this issue is related to daylight saving time (time offset vs time zone) – Rubén Oct 11 '16 at 14:20
2

I missed something basic.

My Windows timezone was set incorrectly @ +10GMT.

Changing it to +8GMT and then adjusting the time in Windows resolved the Gmail issue.

  • See my update to my question above. The original symptom has returned somehow. – Steve May 18 '16 at 7:11
  • 1
    It can be four things... 1) It could be your BIOS battery is going. 2) Your timezone isn't set correctly (Which we ruled out because you changed it 3) It could be malware changing it. or 4) you have software somewhere in your system that you aren't aware of that is syncing up the time to that timezone. – Dale May 18 '16 at 11:15
1

Quoted from www.about.com. (http://email.about.com/od/gmailtips/qt/set_time_zone.htm)

Correct Your Gmail Time Zone

To set your Gmail time zone:

Click the Google apps icon in the top Gmail navigation bar.

Select Calendar on the sheet that comes up.

Click the Settings gear icon (⚙) near your Google Calendar's top right corner.

Select Settings from the menu that popped up.

Select the correct time zone under Your current time zone.

If you cannot find the correct city or time zone, try checking Show all timezones or, if you desire, make sure your country is selected under Country.

Click Save.

If you use Google Chrome, note that a bug in the browser may interfere with your Gmail time zone. Do make sure you use Google Chrome's latest version (click the Chrome menu and select Update Google Chrome if available or About Google Chrome).

source

  • Always give credit when you're offering someone else's words. – ale May 16 '16 at 20:35
  • 1
    Hi Dale. My Google Calendar says my timezone is +8GMT which is the correct time zone, but Gmail behaves as if it is +10GMT still. – Steve May 17 '16 at 2:38
  • What's your computer timezone? – Dale May 17 '16 at 2:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.