38

It's simple to set Gmail to forward all incoming mail to another account. However, the spam filtering is done before that takes place, so any messages that Gmail considers spam will end up in the forwarding account's spam folder.

What I want is to never need to log into the forwarding account. However, in order to check for false positives, if the spam isn't forwarded, I do need to periodically log in, just for that purpose (since otherwise I have no idea that the mail was ever received).

Is it possible to do this? I know that I can use a filter to forward mail matching criteria and set that filter to bypass the spam check, but I need the filter to match all messages, not just some. Using in:spam as the filter criteria gives a message that the in/is/label searches don't apply to incoming mail.

26

You can set up a filter so that no message is sent to the spam folder:

  1. SettingsFiltersCreate a new filter
  2. From: *
  3. Create filter with this search
  4. check Never send it to Spam

From there, you can set up your email forwarding.

  • Many thanks - I didn't know about the "*" trick. – Tony Meyer Dec 14 '10 at 23:53
  • This seems to recently have stopped working... I had a filter set up as "from:*", with the actions "never send to spam", "mark as read" and "forward to address", but a ton of messages (I assume those identified as spam) just stay in my inbox as unread. – Nyerguds Jul 4 '12 at 14:18
  • @Nyerguds: Do you have any other filters which might be impacting that one? – MBraedley Jul 4 '12 at 15:45
  • 2
    @JohnHyland: I can almost guarantee that it won't. In fact, having just tested it with 3 of the 4 addresses that go to my account and one alias on my actual gmail address, and can confirm that it won't catch everything. For instance, it didn't most (all?) of my Facebook notification emails. It probably won't catch any emails sent to a mailing list. – MBraedley Jul 11 '12 at 19:36
  • 4
    Do not use this hint! - Instead, use the answer from enyo just there on this same page. – cregox Apr 23 '13 at 17:22
34

(See below why MBraedley's solution doesn't work):


This method is kind of a hack but it works. I'm happy about any suggestions how to do this otherwise.

Create a filter with:

Doesn't have: SOME RANDOM CHARACTERS YOU'LL PROBABLY NEVER RECEIVE

Create filter with this search »

Check:

✔ Forward it to: YOUR EMAIL
✔ Never send it to Spam
✔ Delete it (optional)

Do not use From: * in your filter. It works sometimes but is not officially supported and stopped working for many of my accounts at random.

From the google support site:

Gmail doesn't recognize special search characters like square brackets, parentheses, currency symbols, the ampersand, the pound sign, and asterisks.

Checkout this thread about gmail's wildcard filters not working anymore.

  • I can confirm that this seems to be working on my normal (non–Google Apps) Gmail account. Thanks @enyo! – bdesham Jul 10 '12 at 22:36
  • Nice hack, just what I needed when the From:* filter method stopped working. – Mike Mazur Aug 15 '12 at 12:07
  • @enyo, There appears to be another bug. When I create a filter as above, it appears to work at first, but if you go back and look at the filter, the 'never send to spam' option is replaced by 'skip inbox'. There is no way to make 'never send to spam' stick. I have tried this on multiple accounts. Maybe this technique still works but this wonky behavior unnerved me so I removed the filters. – Tom Nov 8 '12 at 1:58
  • 2
    I used guidgenerator.com to come up with a good search term like this: 5ebfbd18e29d44c7839a7a31adf414eb (stripped of the hyphens just in case). – Leftium Nov 15 '12 at 7:44
3

I found this solution: https://maxrohde.com/2015/06/18/forward-all-email-from-gmail-even-spam/

I don't know if this would work, but it looks like it would:

  1. Go to settings:

  2. Go to Filters and ‘Create a new Filter’

  3. Set Size less than 500 MB and ‘Create Filter with this search’

  4. Then select ‘Never mark as spam’ and [Create Filter]

Note: This will assure that messages marked as SPAM are forwarded. However, it will also result in all messages you sent being copied into your INBOX automatically. To prevent this, add a second filter:

  1. Create a new filter

  2. In the ‘From’ field put Your Email address and click ‘create filter with this search’.

  3. Tick the option ‘Skip the Inbox (Archive it) and click [Create filter]

All done; all your emails should be forwarded from now on.

  • This worked for me. Gmail has a hard limit of 50 MB per message received anyway, so the size-based filter is a good idea. – Nnnes Sep 17 at 7:08
1

The solution, from SuperUser, that I am using:
https://superuser.com/questions/550341/disable-gmails-spam-filter-when-forwarding-email

The solution to this is not to use Gmail's "forward a copy of incoming mail" feature, but instead to create a filter. Filters are applied to incoming mail before spam detection takes place, giving the option to "never send to spam" in the filter rules. The forwarding filter should use Gmail's "deliveredto:" operator, which handles messages that use plus addressing and messages addressed to mailing lists.

In a nutshell:

  • disable forwarding if you're already using that to redirect messages to your destination address
    • create a filter with the following criterion and actions
    • Has the words deliveredto:your_incoming_address@gmail.com
    • Forward it to your_destination_address@example.com
    • Never send it to spam

I have verified that this approach works.

I have verified that this approach works as well, as of 2018-09-23.

-1

You can go to filter then create a filter and then click the box has the word and write 'is:spam' and then click at the bottom left and then click 'ok' and then tick the box 'never send to spam' and it will solve your problem. It will never send to spam.

  • 2
    According to Google: Filter searches containing "label:", "in:", "is:", or stars criteria (i.e. "has:yellow-star") are not recommended as they will never match incoming mail. – Brian Apr 26 '14 at 0:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.