43

When editing text in Google Spreadsheets, in the formula bar, or editing the name of the sheet, overwrite is toggled, and pressing the insert key (numberpad or 'regular' insert key, numlock active or not) has no effect on this behavior.

I believe I caused this while entering unicode or extended ASCII characters into other webpages. Still unsure of real cause. Google Chrome browser.

3 Answers 3

62

When I double click on the cell itself, and then hit the insert button, the overwrite will toggle off for not just that cell but also for the entire application.

6
  • 14
    Wow what a terrible way to implement that "feature". Thank you.
    – JamesFaix
    Commented Jul 18, 2017 at 19:27
  • 4
    Nice of them to have it behave in a different way to EVERY other application from the past 20+ years.
    – MrYellow
    Commented May 28, 2018 at 23:31
  • I believe it is a bug not a feature, because once I double-clicked and hit insert, then repeatedly hitting insert toggled it on and off which definitely did not happen before.
    – Oliver
    Commented Sep 23, 2018 at 21:24
  • May 2019 featured bug still exists... mind your fingers ^^
    – Stephan
    Commented May 29, 2019 at 19:20
  • 2
    Still confused by this every single time. Some seriously bad UX.
    – MrYellow
    Commented Jul 30, 2019 at 3:22
18

The insert key switches between modes, but for me the cursor has to be in the cell in the spreadsheet. If the cursor is in formula (fx) bar at the top then the insert key has no effect.

2
  • 3
    I agree the trick is to be IN THE CELL. Extremely stupid from Google that when you are IN THE FORMULA BAR, the Insert key does not work! Data entry is data entry is data entry, no matter where you are. DUH congrats Google!
    – Pat
    Commented Jun 17, 2020 at 16:11
  • 3
    That is an absolutely mystifying design decision. I noticed the problem when trying to rename one of the sheets, and the insert key doesn't toggle overwrite mode there either. You have to click into a cell first, then hit escape, then go back to renaming the tab.
    – Desty
    Commented Sep 12, 2020 at 0:08
6

Here's an option if you don't have an insert key: I just closed the Google Sheet in my browser and re-opened. That did the trick.

3
  • Not sure why this was downvoted. I don't have an insert key, so this worked for me. Thanks! Commented Feb 10, 2017 at 16:07
  • 2
    This does did not work for myself, key continues to be "stuck" until double-click method above.
    – MrYellow
    Commented May 28, 2018 at 23:32
  • This issue needs to be fixed it is highly annoying
    – JPK
    Commented Dec 15, 2020 at 15:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.