31

When editing text in Google Spreadsheets, in the formula bar, or editing the name of the sheet, overwrite is toggled, and pressing the insert key (numberpad or 'regular' insert key, numlock active or not) has no effect on this behavior.

I believe I caused this while entering unicode or extended ASCII characters into other webpages. Still unsure of real cause. Google Chrome browser.

46

When I double click on the cell itself, and then hit the insert button, the overwrite will toggle off for not just that cell but also for the entire application.

  • 7
    Wow what a terrible way to implement that "feature". Thank you. – JamesFaix Jul 18 '17 at 19:27
  • 1
    Nice of them to have it behave in a different way to EVERY other application from the past 20+ years. – MrYellow May 28 '18 at 23:31
  • I believe it is a bug not a feature, because once I double-clicked and hit insert, then repeatedly hitting insert toggled it on and off which definitely did not happen before. – Oliver Sep 23 '18 at 21:24
  • May 2019 featured bug still exists... mind your fingers ^^ – Stephan May 29 at 19:20
  • Still confused by this every single time. Some seriously bad UX. – MrYellow Jul 30 at 3:22
11

The insert key switches between modes, but for me the cursor has to be in the cell in the spreadsheet. If the cursor is in formula (fx) bar at the top then the insert key has no effect.

3

Here's an option if you don't have an insert key: I just closed the Google Sheet in my browser and re-opened. That did the trick.

  • Not sure why this was downvoted. I don't have an insert key, so this worked for me. Thanks! – AdrianoFerrari Feb 10 '17 at 16:07
  • This does did not work for myself, key continues to be "stuck" until double-click method above. – MrYellow May 28 '18 at 23:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.