2

Why are 90% of all my incoming emails going to All Mail and not to my Inbox?

  • 1
    And, if you test if things are going to the All Mail folder and bypassing the Inbox by sending something to yourself, make sure you don't use your gmail account to do it (use an external account). Otherwise, gmail sees it as a duplicate (it's just like the sent version!) and sticks it in All Mail. I troubleshot and troubleshot and finally found that nothing was wrong except that I was testing it the wrong way! – Stacey Oct 12 '17 at 1:25
  • For me, a test message sent to gmail shows up fine in mail.google.com/mail/u/0/#inbox. In other words, it shows up in their web mail page's inbox, running in Firefox v78. BUT the very same message does not show up in Thunderbird IMAP's inbox. Rather it shows up in the Thunderbird All Mail folder for the gmail account. BTW, I don't have any filters, nor any forwarding. My Inbox settings are: type: Default; Categories: only grayed out primary is checked; Importance markets: (doesn't matter); Filtered mail: (doesn't matter) The workaround is to look in All Mail. – Elliptical view Jul 9 '20 at 23:58
6

In Gmail, all of your messages always go to "All Mail", hence its name.

What you seem to be experiencing is that some of your incoming messages are skipping the Inbox.

What is most likely happening is that you have a filter that includes the action "Skip the Inbox (Archive it)". "Archive" is just a special action which removes the "inbox" label from messages. (The "inbox" label is a special label, but it's still just a label.)

So the simplest thing would be to check your filters to see what's moving your messages.

There could be some other things going on, but you don't give enough information in your question to do anything but guess.

  • I have similar problems and I deleted all filters to make sure it wasn't a filter. I have several email addresses configured to forward to gmail. I tried them all and one showed up in the Inbox, the other 3 did not and ended up in All Mail. They are all available from search. For the one that worked happens to be the one that I also have configured as "Send Mail As" under Settings->Accounts and Imports. There is some unexplained magic going on behind the scenes. – headdab Sep 17 '18 at 18:31
2

I was having the same problem and finally discovered what was happening. I get a newsletter that would keep going into All Mail and not the inbox. It was being classified as a "Promotion" by Gmail and appeared under the Promotions tab. Go to the gear icon at the top right, select Configure Inbox from the drop down, then uncheck all boxes except Primary. That will force everything into your inbox.

Not the answer you're looking for? Browse other questions tagged or ask your own question.