8

It is about 2 weeks that https://passwords.google.com/ doesn't load my passwords. After logging in to https://passwords.google.com/ I'm stuck with "Loading…".

I first tried to flush cache, reset browser settings and navigate using incognito mode. Then I tried several browsers, computers and internet connections. But nothing changed. I get always the same problem.

I think it is related to my Google account, but no one knows what causes this. Here is a discussion about this glitch, but even there no one knows how to solve it.

Any idea?

  • Are you using https? – ale Aug 21 '16 at 14:46
  • 1
    Yes, as i said in my post, i tried different networks, computers and obviously browsers. I know that it loads for you, as i said it seems to be a problem related to certain Google accounts. – smartmouse Aug 21 '16 at 15:07
  • 1
    Ah, yes, so you did. Mea culpa. I'm afraid I don't have anything else useful to suggest. – ale Aug 21 '16 at 15:08
  • 1
    Is this a consumer @ gmail.com account? If this account was supplied by your work, school, or another organization then the Admins of this group may have disabled or turned off this service. If that's the case you would need to follow up with them. If this is a @ gmail.com account the only other step I can recommend is creating a new account, and confirming this brand new test account doesn't have the same issue. This will just help confirm if the issue is related to the account or not. – Folk Sep 21 '16 at 18:12
  • 1
    Yes, it is a consumer gmail account. Thank you anyway for your reply. – smartmouse Sep 22 '16 at 12:44
2

According to the Google Product Forums thread referenced by the asker, this was a bug that Google eventually fixed sometime before 2016-03-16.

Unfortunately, for this sort of question where there is really no action that the user can take to resolve the issue, the best course of action is to report the issue to Google. Google’s main support article for the passwords feature, “Manage saved passwords from the web”, suggests that https://passwords.google.com/ is considered a part of Chrome:

If you use Chrome sync, or Google Smart Lock for Passwords on Android, you can view the passwords you’ve saved in Chrome and Android on any browser by visiting passwords.google.com.

Google’s instructions for reporting problems with Chrome suggest to use Help -> Report and issue from the menu inside Chrome itself. And, as you already discovered, a place to look for other users with the same issue is the Google Chrome Help Forum

-3

Try to delete "Google Chrome" and re-download it on your laptop or PC, it should work fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.