1

This has nothing to do with my phone syncing with my home PC but when searching Google.com on Chrome for Android three of my previous searches appear in a drop down menu as soon as I click the search field. I've changed the privacy setting on my phone to "Pause" my activity/history/etc. and I've started clearing all the data, cookies, search history etc. via the Chrome menu and I even started using CCleaner (which is awesome overall, gets rid of stuff I didn't even know was there and frees up space on my phone whenever I use it) but none of this stops the previous searches drop down menu. I never asked Google to store everything I search for and it's annoying that this is happening even though I have nothing to hide because I know to use Incognito mode when necessary. How do I stop Google showing my past searches when I click the search field? Besides only browsing from Incognito mode that is.

  • I think its your browser which store history not Google. – serenesat Aug 29 '16 at 9:04
  • Are you logged in when searching? – ale Aug 29 '16 at 14:08
  • I checked and I was logged in. So I logged out and went to Google. I clicked the search field and Google Stackexchange showed up in the drop down menu. I don't know what the problem is here... Maybe my best option is simply not using my mobile internet so much or using Incognito mode all the time... – GaryT. Aug 29 '16 at 15:38
0

Use the "Privacy Checkup" tool found at https://myaccount.google.com.

Specifically, under "Personalize your Google experience", you'll want to turn off (uncheck)

Web & App Activity

Save your search activity on apps and in browsers to make searches faster and get customized experiences in Search, Maps, Now, and other Google products.

Include Chrome browsing history and activity from websites and apps that use Google services

Your searches may also be saved by your browser. This Google Support page also has links to instructions for the most popular web browsers to delete the history in the browser.

  • I turned that off 2 days ago, all the save options are turned off but the searches are still here. The biggest thing that happened after that session of intense attempted problem solving is that something I cleared or turned off deleted all my valuable android bookmarks. You have a great answer though, this definitely should have fixed this. I deleted Chrome then in frustration with a root app but then I kept getting error messages and other browsers are kinda clunky so here I am on Android chrome again... – GaryT. Aug 29 '16 at 15:26
0

You can use incognito windows, delete history (on PC) or log out from your Google account.

Google has a tool to control your activities, You can check it using Myactivity.

You can learn more by help page.

0

Solved! The key is to log out of your Google Account and then make the changes. Here is the Link to follow:

https://android.stackexchange.com/questions/82147/how-can-i-clear-recent-searches-from-search-bar-in-chrome

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.