8

I'm using Slack with Ubuntu Linux 16.04. While I enjoy working with Slack, there is this annoying Slackbot, which keeps repeating the same messages all the time (for example: 'User is in Do not Disturb mode...').

How can I tell Slackbot to stuff off forever?

  • Slackbot is a global admin setting. The messages are either controlled by everyone or just restricted to administrators - depending on your Team security settings. But the messages are global across all channels of the Team, so you can't turn them off locally in a specific channel. see get.slack.help/hc/en-us/articles/… – simo.37920 Dec 15 '16 at 2:29
  • 2
    Thanks for reply. Shutting slackbot off in all channels is actually what I'm after. I've already removed the 'x' in Slackbot Responses >> [ ] Enable Slackbot Responses. However, this bot keeps annoying everybody with the ever same messages ... – Bunjip Dec 15 '16 at 8:06
2

It looks like you can't disable Slackbot for all channels, according to Slack support.

But you can at least disable the channel suggestions by selecting the option of "No, Turn Them Off" under these suggestions, or go to Preferences > Advanced > Other Options and untick the option to send these occasionally.

0

While you can't disable Slackbot for any particular channel, if you have permission to delete Slackbot's messages, you can install this bot, which will delete Slackbot's automated responses for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.