1 of 2

Go the your Facebook settings on the "Language and Region" tab and set the "Formats for dates, times and numbers" under "Region format" to something appropriate, like "South Africa (English)" Screenshot of the relevant setting, which is directly linked anyway