Go the your [Facebook settings on the "Language and Region" tab][1] and set the "Formats for dates, times and numbers" under "Region format" to something appropriate, like "South Africa (English)"
[![Screenshot of the relevant setting, which is directly linked anyway][2]][2]


  [1]: https://web.facebook.com/settings?tab=language&section=region&view
  [2]: https://i.stack.imgur.com/Ih9TR.png