It's because those GIFs are MP4s coded with high levels (6.0 etc.) that normal hardware can't play. In Chrome: Disable "Hardware-accelerated video" decode in chrome://flags (type this is address bar) Keep "normal" hardware acceleration on! Chrome > Settings > Advanced > System > Use hardware acceleration when available

Only top voted, non community-wiki answers of a minimum length are eligible