1

I'm currently abroad in Japan and while my overall Twitter language is still English, when I click the Moments tab all the moments are in Japanese. My settings are using English for the language and United States for my country.

Using a lang query string, like https://twitter.com/i/moments?lang=en does not make it show English moments.

How can I get moments in English again while abroad?

1 Answer 1

1

That sounds like a possible bug in the site code. Testing the Moments page in other languages looks like it applies the language settings to the main page elements (header, footer, etc.) but not to the Moments themselves. Here are some things to try:

1. Try a different client

If you have a smart phone or tablet, try the Android or iOS Twitter app -- both of which often behave differently than the web app -- to see if they show the Moments in the correct language.

2. Try to contact Twitter support

If you can get a hold of someone on the Twitter support staff, they may be able to help. Two options are through Twitter via @TwitterSupport or by email at [email protected].

If neither of those options get a response from a real person, you could also try tweeting @TwitterMoments, which may or may not get human attention.

3. Submit a ticket

You can submit a problem ticket through Twitter's Help Center. Though this may eventually result in the problem being fixed, you probably won't receive a response.

From the Help Center page, select Profile. When asked to select a reason for your ticket, choose other.

3
  • 1
    I tried contacting them via that account, but it is a bot. When I ask about Moments, it just tells me to look at help.twitter.com/en/using-twitter/twitter-moments which is not helpful.
    – nbkhope
    Jan 19, 2018 at 5:06
  • @nbkhope That's a shame that it's a bot-controlled account. I've updated my answer to add some other options. I think trying either the Android or iOS app is your best bet.
    – freginold
    Jan 19, 2018 at 11:58
  • This is not an answer to the question. Aug 15, 2018 at 8:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.