I have used http://www.deezer.com/ for a while now and it has always been in English. Recently it is showing everything in French. Google Chrome will auto-translate pretty OK but why is Deezer suddenly French?

1 Answer 1


It turns out the language in settings was set to French. Don't remember ever setting that and not sure why I would but there you go.

Go to 'Cog' (top right) > Settings

enter image description here

Then select your preferred language > Save

enter image description here

Also refer here for Chrome settings

Why does the internet think I'm French?


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.