2

There are lots of questions out there asking how to add birthdays and anniversaries to Google Calendar. I know how to auto-populate birthdays from Google Contacts to Google Calendar. And I know how to manually add anniversaries to Google Calendar as recurring events. My question is:

Is there a way to auto-populate anniversaries from Google Contacts to Google Calendar? Thanks.

7
  • 1
    There's an "anniversary" field on contacts. Mine populate my calendar. Don't yours?
    – ale
    Aug 23 '19 at 14:49
  • Mine do not auto-populate. I add an Event, set the date, and then select "Anniversary" from the drop-down, but nothing appears on my calendar, neither on the actual date of the original event (the wedding) nor on the anniversary dates in subsequent years.
    – Josh
    Aug 23 '19 at 14:52
  • How long do you wait? It's not generally instantaneous.
    – ale
    Aug 23 '19 at 14:53
  • @ale, to which calendar do your anniversaries populate?
    – Josh
    Aug 23 '19 at 14:53
  • Most of them were entered last year when I migrated from Outlook to the Google Suite. I just added one manually today.
    – Josh
    Aug 23 '19 at 14:54
2

It's imperfect, but if you put a date in the "Anniversary" field in Google Contacts, it will add annual events to Google Calendar on the "Birthdays" calendar with the text "John Doe's Anniversary". Of course, you'll need to display the Birthday calendar as well.

"Birthday" is a poor name for that calendar considering it's not just birthdays, but it's what we've got.

1
  • 1
    I just discovered that the name of the Birthdays calendar can be changed. Click the three dots > Settings > Name.
    – Josh
    Aug 23 '19 at 16:13
-1

The answer from ale here is correct, including the comment from Josh on the ability to rename the Birthday clendar to 'Contact Events' or something more adequate, as it can show anniversaries and other events from contacts.

However, if like me the 'Birthday' calendar simply does not appear in your Desktop/Laptop Google Calendar, under 'My Calendars' section, it is probably disabled on your mobile (which is crazy - Google should change that, but..). You'll need to go to Settings on you mobile Google Calendar and enable Birthdays. once you do that, it will appear on the laptop/desktop version of Google Calendar and you can rename it if you like. See this Google help question and Answer on this issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.