In Meta Business Suite, I want to create a custom audience from people who interacted with content from my professional Instagram account, as described in this article of the Meta Business Help Center.

What I tried:
I added my Instagram account under "business settings/Instagram accounts". I also added my Facebook profile under "people who have access to" my Instagram account (don't know if this is necessary). Then I go to "audiences" in the burger menu and click on "create custom audience". Here I choose my Instagram account under "Meta sources".

Here the problem occurs: my Instagram account is not shown in the list.
My Instagram Account is definitely a professional account. What's wrong?



1 Answer 1


Looks like you have to go into Business Settings in your Business Manager > Accounts > Instagram accounts > Connected assets > Add assets, then select your ad account. Worked for me, hope it does for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.