0

I'm having a problem with my Twitter account. It was running smoothly since 2012 but I started to notice (for over a year now) that my tweets are not showing in the search results as well as the hashtags search -- under Top or All tweets -- when I search for them from another account. However, I can see them when I use my own account.

To clarify this more, MY ACCOUNT IS ACTING AS IF IT WAS PRIVATE, and it's not. I tried to change passwords, deactivation & reactivation, but nothing worked & yes I contacted the support multiple times with no reply.

If anyone can help, I appreciate it because I don't want to lose my 15K followers by creating a new account.

1

If your Tweets have never been public (in other words, you've always had your Tweets protected in your settings), your updates should never show up in Twitter search or other public search engines.

From Twitter Help Center:

While we may not show every Tweet in search results, here are a few reasons you may not be seeing yours:

  • Are you viewing only Top results? Try selecting Live (or All Tweets if you’re on a mobile device) at the top of the search results page, which will show you more Tweets for that search query.
  • Are your Tweets protected? If so, only approved followers can see your protected Tweets in search results.
  • Have you confirmed your email address? Make sure you have completed your account set-up and that you have a confirmed email address associated with it.

Note: Twitter search intends to bring you closer to content most relevant to you. Our results are refined to combat spam and increase relevance to provide the best possible search experience. Our Support team is unable to force individual Tweets into search.

  • This is related qr.ae/1Y69Yl – serenesat Jun 30 '16 at 7:03
  • 1
    That's the thing my profile has been always "public" so that's why I don't know what is happening ;( & yes I went through all the help pages there is nothing wrong regarding to confirming email, etc as I said my twitter is 4 years old by now & it was working fine till lately this happened – conf2k Jun 30 '16 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.