17

It's been a few days now and nothing has changed, but here's the problem:

  • Compose a new mail
  • Write a few words, let's do this for the explanation: "---------------"
  • Go straight in the middle, select one character
  • Cut it with Shift + Del (very classical way)
  • Now paste it with Shift + Ins (very classical way)

And here's the result:

select one char

after copy then paste the char

And this behavior is the same in general: you cut + want to paste, Gmail adds space after, and sometimes (yes, sometimes not all the time!) before too.

How do I get it to stop doing that?

18
  • 2
    At the guy who asked to close it because "This question does not appear to be about computer software or computer hardware within the scope defined in the help center.". Please tell me why it's not about computer software? Aren't we in the superuser world? What am I missing? Jan 20 '18 at 12:58
  • 2
    Also, does it also happen if you use CTRL-X to cut and CTRL-V to paste? That's a different way to copy/paste, and is often also interpret differently in different systems. For example, if you paste in Powershell using CTRL-V, it also executes that row. But if you Shift-insert, it does paste, but not execute.
    – LPChip
    Jan 20 '18 at 14:11
  • 1
    @LPChip It's not a question to ask because all programs: Notepad++, Notepad, PyCharm, PhpStorm, Word, Visual Studio, and the list could go on and on, do behave like this. This is almost a de-facto standard. Moreover gmail has always had this "de-facto standard" for years. That's why I hate the guy responsible for this because I'm loosing a lot of time copy then paste into notepad and re-cut again to be able to paste. Jan 20 '18 at 14:16
  • 5
    I'm able to reproduce this problem in both Gmail and Google Calendar, in both Chrome and Firefox private windows, using all combinations of Ctrl+C, Ctrl+Insert, Ctrl+X, Shift+Delete, Ctrl+V, and Shift+Insert. The only requirement is the text be pasted into one of Google's HTML-enabled text elements. If I paste into a Gmail draft with "Plain text mode" enabled, for example, no spaces are added. Nor are spaces added if I paste as plain text (Ctrl+Shift+V).
    – thinkterry
    Jan 30 '18 at 3:43
  • 2
    @OliverPons I meant, fixed in the sense that trying Jim Luschen's solution worked, although I have to give up html. I agree that this is a TERRIBLE 'feature' to automatically add spaces on paste like that. Aug 19 '18 at 11:49
5

I found the switch to shut this off.

Next to the garbage can icon at the bottom of the Gmail editor window is a down-arrow that brings up a list of options. One of these options is:

Plain text mode

If this mode is unchecked (not active) then you get all the annoying spaces inserted when you paste text. By checking this option, the behavior returns to normal editing conventions.

I have no idea why this option exists.

4
  • 8
    When you check this option, it removes all the "HTML" things you've put into your mail: images and text formatting. Even though the copy/paste works, this is not a viable option IMHO... Apr 25 '18 at 22:45
  • 6
    You are right. Plain text mode removes the objectionable behavior you originally described, but at the cost of killing any text editing beyond ACSII content. It is clear that Google messed up with their Gmail editor. It's really annoying, isn't it? Too bad there's no way to let them know. Apr 27 '18 at 22:02
  • 3
    It's even worse. Copy/paste now also messes up the formatting, but you cannot see that from within GMail. Your recipients however will see a very unprofessional mix of fonts and sizes, which is absolutely infuriating and inexcusable. Or is it just me?
    – Julian
    May 18 '18 at 9:47
  • @Julian It's not just you, same problem here
    – root
    Jul 22 '18 at 15:05
4

Not only the spaces are a problem, but also the messed up formatting, as @Julian mentions in a comment.

Many users should send feedback to Gmail so that they decide to fix it.

2
  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. - From Review
    – serenesat
    Jul 22 '18 at 17:21
  • 1
    This is a Gmail bug. The question is "How do I get it to stop doing that?". The way to achieve that is to ask the Gmail team to fix the bug.
    – root
    Jul 22 '18 at 18:27
4

If you use Ctrl+Shift+V it will paste as plain text only, which doesn't add any spaces.

1
  • That works for me. Unbelievable! Thank you so much, I could never have found that on my own. Mar 8 at 18:02
0

What worked for me (getting rid of the auto space and also keeping my hyperlinks) was sending the email to myself first and copying the text from the sent email. For some reason when I copied the text from my draft I got the autospace, but when I copied it from my sent email I didn't.

I was sending 200+ generic emails, so this little trick really helped...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.