1

I'm subscribed to an external calendar in Google Calendar, but it shows in a separate column. How do I "merge" it with my main calendar, so that events from it show in the same column as my events? This used to be the normal behaviour, but it seems to have changed recently.

For example I'm subscribed to Public Holidays in Quebec. It used to appear like this in the Day view, with the event in question in brackets:

Firstname Lastname |
-------------------+
[holiday]          |
-------------------+
09:00  Work        |
       09:00-17:00 |

Now it appears like this:

Firstname Lastname | Public Holidays in Quebec |
-------------------+---------------------------+
                   | [holiday]                 |
-------------------+---------------------------+
09:00  Work        |                           |
       09:00-17:00 |                           |

More details

I'm aware there's a builtin "Holidays in Canada" calendar that shows in the main column, but it's also got a bunch of holidays in the rest of Canada that I don't care about, like Feb 17 2020 has Family Day (regional holiday), Islander Day (Prince Edward Island), Louis Riel Day (Manitoba), and Nova Scotia Heritage Day (Nova Scotia). These are just clutter to me.

This applies to other cases too. For example I'm also subscribed to my work schedule and two calendars for an organization I volunteer with, and I want them to appear on my main calendar too.

I want the events from external calendars to show in a different color from my main.

Related: How can I add the British Columbia holidays to my Google Calendar?

I read Automatically create events in Google Calendar from external source, but the answers require using the Calendar API and setting up a scheduled job, which is more effort and complication than I'd like.

  • What view are you using for this? Are you using G Suite? I used shared calendars of many types and none of mine do that. – ale Jun 25 at 15:27
  • @ale I'm using the "Day" view. This affects my personal Google account as well as my company G Suite account. – wjandrea Jun 25 at 16:14
1

Go into Settings | View Options and uncheck "View calendars side by side in Day View".

  • This works perfectly for my personal calendar, thanks! However, for my work calendar, I need to show my teammates calendars in separate columns, but this merges all of them. Is there a way to select calendars to show side by side? This used to be the normal behaviour. My teammates calendars are on the same domain. – wjandrea Jun 25 at 16:51
  • That is probably something you need to ask your G Suite admin. – ale Jun 25 at 17:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.