3

Using Google Sheets I'm trying to populate a list of countries with (among others) names, ISO-alfa2 code, and flags. I use this IMAGE() and ArrayFormula() to get the flags from URL in my private server:

=ARRAYFORMULA( IMAGE(URL/"&P7:P224&".png")) Where URL is the link hosting the flags, RANGE P7:P222 contains ISO 3166-1 alpha-2 codes (all in upper case). The flags in the URL labeled with the same ISO codes except with lower case.

As shown in the attached picture, some flags randomly don't show up despite that all ISO codes have been entered the same way (all upper case) and all the flags images are lower case. enter image description here

Things I tried:

When using LOWER(P7:P222), some flags don't show up. When using UPPER(P7:P222) some different flags don't show up. I used both Chrome and Firefox to view and edit the sheet.

Is there a way to fix this without changing the range to lower case or the images name to upper case? Is it something wrong with my formula or is it just the browser, HTTP/GET or Google app is misbehaving? Any input is greatly appreciated!

UPDATE: Looks like this has nothing to do with case-sensitivity as I changed range P7:P221 to LOWER case, however, the problem persists and some images randomly don't show up.. Does this mean the IMAGE() formula is broken?

IMPORTANT UPDATE: Further tested the following:

  • Usedimage() to get images from Google Driver: no luck.
  • Inserted images manually: they disappear after a while.
  • Used ImageKit addon to insert images from URL (Google Driver and other servers): and via upload from my PC: Yield same results as using image() formula.

I also changed the title of the question accordingly.

Link to the sheet: https://docs.google.com/spreadsheets/d/1nd1gbRm0eD2lvUa58jHjacdTYd7fqhGP4YpYeMZWRzo/edit?usp=sharing

10
  • Add demo spreadsheet shared with anyone with the link to view.
    – Rubén
    Apr 11, 2020 at 0:01
  • Rubén, updated with an editable version of the sheet.
    – Abbe Satty
    Apr 11, 2020 at 0:44
  • IHMO demo spreadsheets should not be shared with edit access for anyone with the link b/c demo spreadsheet should not be changed.
    – Rubén
    Apr 11, 2020 at 1:03
  • The shared spreadsheet doesn't show the problem.
    – Rubén
    Apr 11, 2020 at 1:03
  • Sharing the sheet dramatically altered the problem, more flags showed up, still, some will not show up, there's no logical explanation as to why they don't as the sheet structure is the same. Also, I disabled the edit feature I'm the shared sheet. Thanks for the tip!
    – Abbe Satty
    Apr 11, 2020 at 1:27

3 Answers 3

3

It turned out that the problem cause was client-specific. In my case, it was that the adblocker (uBlock) somehow blocking most of the images indiscriminately.

The solution: Disabled uBlock adblocker on the relevant Google sheets page.

2

It was the following Chrome Extension for me: Google Docs Offline

Disabling that solved the issue for me.

1
  • That worked for me. But it's not a convenient fix because you lose local caching... Jun 7, 2021 at 12:46
-1

In my case disabling the Google Docs Offline extension fixed the issue.

1
  • How is this not the same as the answer by @KennethPoulsen?
    – Tedinoz
    Aug 1, 2022 at 1:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.