15

Has Gmail team introduced some change to "reply" mechanism recently?

Here is, what I found (can't figure out exact time frames -- sorry):

  1. Some time ago:

    • in any conversation between me and someone, no matter if I clicked Reply in mine or his/her e-mail, I was always replying to him/her, never to myself (not so obvious, but very handy and useful!),

    • if somehow I managed to reply to myself and sent such e-mail, it was immediately moved to Inbox and presented in bold (unread message), so I could at once find out, that I made a mistake and instead of sending my reply to OP, I sent it to myself.

  2. Currently:

    • in any conversation between me and someone, if I click Reply on e-mail sent by him/her I'm replying to him/her, and if I click on any e-mail sent by me, I'm replying to myself (reasonable -- but completely not useful!),

    • if I reply to myself, I never see this e-mail in Inbox, it only stays in Outbox as sent.

Original (previous) solution wasn't maybe too obvious, but it was extremely usable. No matter in which part of me-someone conversation I clicked Reply, composed message was always sent to OP and never to myself. So, there was no problem at all, if I wanted to send another message, after previously sent one, without waiting for a possible reply to it.

If, I'm not mistaken, the same scheme is implemented in many other mail clients like Thunderbird etc.

Now, if I click Reply on "my part" of conversation, I'm replying to myself. So, If I want to send another message, after previously sent one, I have to always click Reply on OP e-mail, not on my own. I don't know any situation, where someone would like to reply to himself, so I find this very useless.

Because -- in addition -- I'm not "alerted", that I sent a reply to myself (no sign of e-mail in Inbox, though it should be there, as I sent it to myself), I'm simply loosing track of who I'm replying to.

I can't count, how many conversations I now have broken or at least suspended for some time, because I found out after few days, that OP didn't received my reply at all. I clicked Reply on my own e-mail and sent the whole message to myself, not to the person, I actually wanted to sent it to.

Can someone confirm this change? Is this permanent? Or just a bug, that is going to be fixed? Can anyone write anything about logic behind introducing this change (if there is any logic behind it)?

17

Finally, I have found source of the problem and want to share it for others, having the same problem.

It turned out, that I accidentally unchecked Treat as an alias checkbox for my main account, on SettingsAccounts and Import[account name]edit info. After checking it back (this time for all my accounts) entire Reply functionality got back to normal.

Turns out, that this is not a bug, but some kind of feature, about which Google is aware and have it described in details. Most important parts:

If you use Gmail's Send mail as feature to send messages on behalf of another email account, you may encounter the following issues: (...) If you receive a message from a Send mail as address and you click Reply, the To: field is incorrectly populated with your primary address. (...) These issues occur because Gmail treats your Send mail as address as an alias of your primary address. You can change this behavior in your mail settings by deselecting Treat as an alias.

And now, comes the best part. Either I'm missing something, or in my case the solution was to do something exactly opposite to what Google suggests! From my understanding of above text (correct me, if I'm wrong), I should deselect Treat as an alias to fix the problem, that To: field is being incorrectly populated with my primary address (that is exactly, what was happening to me).

Well, the problem is, that I was experiencing above mentioned problems when I had Treat as an alias checkbox unselected. And selecting it back solved the problem. Only after then my To: field started to become correctly populated—exactly how it is described in Kevan Sheridan's answer.

3

I can confirm that if I click "Reply" in a message I sent in a thread, the action taken is as if I was resending the message. The TO address is the same person as the original TO address.

If I want to send (or reply) a message to myself, I need to add my e-mail address. Yes, messages I send this way do appear in my Inbox as new.

If you have seen this change recently, is it possible that some change you made altered the action?

Items to check:

  • Recent Browser Extension(s) added (disable them test, enable after)
  • Any new "Labs" additions to Gmail? (Found in Gmail settings)
  • Do other browsers act the same?
  • Thanks for your feedback. I haven't installed any extensions for ages but checking other browsers and Labs does sound reasonable. I'm surprised, that I didn't come with this myself... :/ – trejder Feb 15 '14 at 10:21
  • I have disabled all Labs extensions, by using labs=0 addition in Gmail's starting link, and the problem remains, so this seems to be unrelated to Labs extensions. I have narrowed, that problem relates to my account (doesn't happen on other Gmail's accounts) and that it appears in all browsers. Since I haven't changed anything (Labs, config changes) in Gmail for months and I'm using the same browser all for all the time, this becomes really strange case. – trejder Feb 17 '14 at 11:07
  • Is there any official support mailing / e-mail / forum for Gmail application? – trejder Feb 17 '14 at 14:37
  • 1
    There are Gmail support forums, but are difficult to search for items like this. Good that you have multiple accounts to compare and it is also good that you narrowed it down to the single account. Question: Are all of the accounts Gmail? Or is there a Gmail / Google Apps mix? Sometimes Apps accounts work differently than straight Gmail accounts. If you can, compare the Gmail General Settings on two accounts that are both Gmail (not Apps) accounts. Check over the Reply settings specifically. Even change, then set again these settings. This "change then set back" worked for me once. – Kevan Sheridan Feb 17 '14 at 20:52
  • No, I have only "pure" Gmail accounts. I haven't changed any of the settings for months. But since you're referring to "set and reset" technique, then I think I might be a victim of some of Gmail's stupidity. I'll try this method. Thanks. – trejder Feb 17 '14 at 20:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.