6

Just like the title says. I have a work label marked with a exclamation point in front of it so that it's always at the top of my label list. The list looks something like this:

  • !Work
  • Alice
  • Mark
  • Zach

However, if I have the !Work label and a name tagged to a same message, !Work always displays last. So in my inbox I'll have a series of messages that are labeled like this:

  • Alice, !Work
  • Mark, Zach, !Work
  • Alice, Zach, !Work

And so on. This is only in my inbox. If I click on the individual emails, the labels are ordered properly (i.e.: !Work, Alice, Zach). Does anyone know how to fix this issue? It only started doing this recently and I haven't changed how I apply labels to messages so I have no idea what caused it.

  • Can you please clarify what you mean by 'label list'? Are you referring to the left panel, or maybe the (horizontal) list of labels associated with each specific email? – Max Nov 12 '13 at 19:22
  • 1
    The order seams to be the order in which you applied the labels. The label you applied first at the start and the label you applied last in the end. Don't know what to do about it, though. – Punchlinern Mar 9 '14 at 11:29
1

Use another special character like underscore '_'.

Exclamation point can be interpreted as code and may behave differently depending on the context the labels are displayed.

Underscore seems to work fine in this case, '_Work' appears first in the list of folders (left hand side column) and the first in individual email label(horizontal list at the top).

0

By default, Gmail will place at the top of the list any labels that is bold, which means it contains unread emails in it. Labels that aren't bold sink at the bottom, and might even be hidden and only appear when you hover the bottom of the list and click on 'More'.

If you wish that one label you have appear regardless of whether it contains any unread messages in it, you should go to 'Manage labels' (same as Settings > Labels) and check the value for your !Work label for both columns 'Show in labels list' and 'Show in message list'. It should be 'Show', as opposed to 'Show if unread'. This will force it to appear in the list even though Gmail assumes you wouldn't need it since it doesn't have anything new/unread in it (and you can still go to the bottom of the list to see it).

The option 'Show if unread' is somewhat new, I remember it not being there a few years ago, and when the switch occurred Gmail must have defaulted all labels to 'Show if unread'. I did find a blog post that talks about the feature in 2011, so not so new. Also, this video might provide some clues as to how to best use that feature.

  • I think you've misread the question. The OP is asking about the order of labels as they appear in the conversation list. – ale Nov 12 '13 at 17:09
  • Are you saying 'label list' doesn't refer to the left panel? – Max Nov 12 '13 at 18:52
  • 1
    That's how I'm reading the question, but we probably need the OP here to clarify. – ale Nov 12 '13 at 18:54
  • Your information is incorrect. – Daniel Springer Jan 11 '16 at 6:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.